Bugs and Improvements

The last digits of the screens are 104d5, 3bfb8, f54fc, 5434b
which screen is where?


When attempting to change the deadline parameter for step 1 of a loan it gets stuck on [In Progress…]

weird bug I found:

I clicked the top search result on the search box when it was empty “Montem (OT-580b)”, and APEX changed the selection midway in the calculations to "LS-300c (Griffonstone) ", which bugged the sliders causing the FTL slider to show up. Once I clicked the FTL slider, the entire ship route recalculated itself to Griffonstone’s flight path, returning to “normal” (which is not what I intended in the first place).

(idk what would’ve happened if I clicked depart before this, maybe this could lead to a FTL shipping exploit?)

P.S: Could this possibly be a double bit-flip of some kind? Griffonstone is by default #4 on the search list so there would have to be changes in the first and third byte for this to happen (1st bit going from 1 to 0, 3rd bit going from 0 to 4)

Add arrows to the top and bottom of the production queue. The arrows “wrap around” with the top arrow sending the item to the bottom of the queue and the bottom arrow sending the item to the top of the queue.



There is a bug when queuing carbon production in the INC.

  • Select the production template first (here MAI > C)
  • Select the production filter (here C)

The production template is still displaying MAI, but in the input it’s expecting HCP (the default product)

  • Select the production template again to fix that.

There is a series of screenshot:

Unless I keep playing the game literally every single 24hr and extending loan contracts, they will get breached. So if I have any active loans at all, I cannot take any break for any reason or risk the game auto-terminating a contract.

I would really like more extension time for missed loan payments. Or some way to configure this. I cannot take a vacation or miss a day for any reason with this.


1 Like

There appears to be a bug with govenors. The player does not have a base on the planet and is not recorded in the planet govenor database but has got the office?

That isn’t a bug. You can be governor without having a base. You will only be added to the previous governors list once your current term expires.

1 Like

Found a bug I probably encountered many a time but just brushed it off as lag. I’m trying to move the maximum amount of TI into my ship that will fit, but nothing happens. I assume there’s some rounding thing going on in the UI that makes the client send a request to move 90 TI instead of 89 TI. I have 404.99t of free space, 90 TI would need 405t, so the MAX option should try to move 89 TI, but I assume it tries to move 90 because MTRA also offers me the possibility to move 90 which results in an error (“Insufficient capacity.”) when tried. When I set the slider to 89 it works as expected.

I do use the extension PMMG in that screenshot, but I tried it in Chrome without PMMG and the bug is the same.

That bug has existed for years, I believe it’s a known behavior. It’s quite rare to see it happen, I haven’t run across it in AGES.

1 Like

Thank you I think Firefreak for suggesting this solution to COGC voting @ scale, which is WAY better than getting 30 notifications a week. Do you think we can get an autovote feature for the COGC? Cause my vote never changes, and this is getting kind of old.

1 Like

It is not set in stone yet, but control over the CoGC might eventually go to the local government with the upcoming Politics update.


How would that work for a planet that has a CoGC but not a government? Or is government going to be a required feature for even frontier planets.

It could be that a planet will have a form of government depending on population or amount of companies settled.
While the now ADM building would unlock government actions like programs but it wouldn’t be needed to form a government or council

Can we update the consistency of naming when systems are named specially?
For example, in most screens the Antares II system will have all its planets named things like Antares II d. But in the BS buffer, it’s called ZV-759d.

Then there’s the Antares III system, which is never searchable by Antares III (using PLI, you cannot find Antares III) You have to use ZV-194. But the system is named Antares III. I’m curious if this is an issue with systems named by players, since Acetares has a similar problem. It may also be an issue with the PLI buffer.
If you type in Acetares, you only get one named planet (there are two in the system). It seems that the planet you do get was named after the system was renamed, while the other was named before the system was renamed.
Perhaps the system search cache needs to be rebuilt for that system when a rename occurs?

1 Like

Thanks for the feedback! I noticed that a while ago as well and created a ticket for fixing the search.

Are consumption events supposed to get wrapped up into “one per 24h period?”

Screenshot 2023-11-06 at 3.06.52 PM

This has been going on for some time (the next two most recent pairs)

Screenshot 2023-11-06 at 3.07.02 PM

Screenshot 2023-11-06 at 3.07.12 PM

Digging into it, it appears that I was right at the cusp between “have enough” and “don’t have enough” with one of my production lines finishing just slightly offset from 24h. This would result in a consumption event, and then 15 min later, another consumption event as something was produced that wasn’t consumed in the first one.

Bringing in enough consumables to oversupply for a period of time had the single consumption event.

So I have a bug. I’m currently in orbit of QQ-001, and am trying to fly to any planet in QQ-001. Every planet gives the same thing: “Invalid”. I can go to another system, but I can’t go to anything in the system that I am in.

No Flight In System

Thanks for the bug report. This is a known bug that we haven’t fixed yet. In the meantime it is best to jump to a neighboring system and back.

1000 clicks later… I’m halfway!

Would be awesome if we could have a multiplier so increasing space is a weeee bit easier.