Planet Map, System Info not rendering anymore

Since last update or a browser udpate at the same time, those two virws now are red and show a text in the center “Component ailed to Render”, making a lot of the workflows extremely inconvenient.

This is at least for:

  • PLI (Planet Info)
  • MS (System Map)

PLI blocks creation of a new base to my knowledge as that is the view where the create base button is.

Thanks for the bug report. I tried to recreate it, but failed so far.

  • Does this error occur for any surface map in PLI?
  • Does this error occur if you open APEX in a private browsing tab?
  • Which browser do you use?
  • Yes.
  • Yes
  • MS edge on Windwos 11 on a Surface Pro 8

In the console I see a lot of:


   Error: Error creating WebGL context.
at new ou (three.module.js:26280:12)
at react-three-fiber.esm.js:1685:20
at react-three-fiber.esm.js:1746:24
at react-three-fiber.esm.js:1558:7
at hs (react-dom.production.min.js:219:180)
at Mu (react-dom.production.min.js:259:160)
at t.unstable_runWithPriority (scheduler.production.min.js:18:343)
at Bi (react-dom.production.min.js:122:325)
at Tu (react-dom.production.min.js:252:279)
at hu (react-dom.production.min.js:243:371)

indicating it can not create a render surface.

It should, IMHO, at least handle this type of error better - just because the map does not render does not mean all the other infos in the component should not render. Instead of this error, it should handle the error and show a “map failed to render” in the map, but show me the other elements still. Especailly on PI - the planet is nice, but I find no actual use in it.

Whoa, exotic setup. And I’m a Linux user saying that. :stuck_out_tongue: :rofl:

(I bet it’s the MS edge.)

@DrTom - have you tried a different browser?
Have you tried a “hard refresh” - Ctrl + F5?
I usually use Firefox on Windows, but I just tried Edge and it works fine for me there.