Bugs and Improvements

Getting a annoying error in CONTD when trying to update a condition.
image
Clicking the Save button has no effect.

The only way I have found is to get this updated is to redo the whole contract from the template selection dropdown.

In Sector TO I noticed systems with the designator OT. Not sure if this is a typo or intentional.

OT-889 (and planets)
OT-115 (and planets)
OT-580 (and planets)
OT-442 (and planets)

TO-392 is the same as the sector designator. Given one system matches is it possible the sector is reversed?

Can we pretty please get recurring and multiple items with a contract, it’s getting unbelievable Unbearable playing with so many contracts I have to fill and create.

This falls in the “weird thing happened to me once (ever), but I wasn’t able to reproduce it again” … but there have been other rare reports from others with similar symptoms.

With a ship docked at some place, the drag from the base or warehouse inventory to the ship inventory refuses to happen. (Aside: there are two different ways of opening the ship inventory - via INV opens up INV bb737bc8 while via FLT it opens up SHPI AVI-03KC0 - I seem to recall it working with one and not the other(?) until it started working at both again… but that was some time back and I’m not certain about that reproducibility chain).

This has also been reported with similar problems in #help on Discord recently where a similar “dragging it from Antares warehouse to the ship cargo hold didn’t work”.

A workaround for this is to use MTRA which doesn’t involve dragging and has certainty with which inventories are colocated (you can’t be dragging to the wrong ship - though this wasn’t the case in any of the situations)).

The awkward part is that this has only happened to me once in several months of play and the other people having trouble with it is rare.

Another example of this can be seen in Apex Chat logs for Feb 19th in the help channel where another user had issues that seemed to be similar in symptoms.

When transfering inventory to the capacity of a storage unit, 1000 units for example which does fit the 1k option is not available but if you select max 1k is what is transfered.

It’s been happening for a while and is really annoying.

Hello,

When i start a fly, then abort it, the ship comes back. at this moment i can’t put goods into cargo. i have red cross like cargo is not reachable

so, i have to start a new fly to the same destination, wait, then i’ll be able to put goods in cargo.

thanks

Sounds like your ship is in orbit around the planet you just left. That is where it ends up if you abort right after takeoff but before it has jumped to the next sector. You do have to fly back and land on the planet before you can put stuff in cargo.

ho really ? thanks Ogrebeef, i will be more carefull the next time.

I got a weird notification bug today in NOTS. I received a notification that just says “[failed to render notification]”. The rest of NOTS is working perfectly.

Clicking this notification gives no popup buffer.

I tried disabling my broswer extensions and got the same result. Checking NOTS on the browser version gave me the same result.

I ran into one person in the help chat that received the same error at the same time.

image

Bug in leaderboards


Pulling up the top ranks works fine but if you click ‘load more’ it adds 26-50 but if you click it again it replaces 26-50 with 51-75 leaving 1-25 on the screen.

The last bullet point under ‘Free License’ on Prosperous Universe reads:

Contract Termination
Cancel contracts when you or your business partner change their mind or when one cannot fulfill the arrangement.

This can be confusing to players since the only business partners that a FREE license player has access to are the NPC faction contracts and those cannot be canceled (they can be rejected, but you can’t terminate an in progress one).

This item should probably be moved to the BASIC license column.

Within NOTIG, I would like the ability to filter out “fulfilled loan condition”, which is what all of these notifications are. I’ve got dozens of loans active right now and I get 3-5 notifications a day of just people making loan payments and I’d really like to be able to filter them out. There have been a few instances of me just missing important things because of the volume of notifications.

I have completed the calculation of the functional model for calculating the Production Fee for the production of material. From the recipes I have verified, I get the impression that they all work and the test calculation model is correct. I encountered only one inconsistency, which in my view can only be explained by a “lost” error in the calculation formula on the server side.

This is a Cleanroom production line. Compared to my calculation, this increases the fee by 0.01 unit for some recipes.

One of the original hypotheses for why this happens was, for example, the inclusion of 100 units in the time data in the calculation, but when verified on another planet, it turned out that this deviation is the same as the amount and is not relatively increased (0.01 in addition to the fee). Additionally, it does not occur on all recipes, and it does not occur on all planets. So the most likely reason will be specific rounding for some CLR recipes (SWF, MWF, LDI, SFE and occasionally NCS).

It would be nice if we could repair our bases from materials within our ships. The “inventory selector” system that we use for HQ upgrades would work great here. It becomes a problem because you can have a base with not enough free space to use the “unload” command. So now I must manually unload everything to repair the base.