Bugs and Improvements

grafik

Thanks, that 0-provisioning contracts will be fixed with the Liquidity release

I demolished a STO on Kiruna (going from 3 to 2), but I still have inventory space available as if I had 3 STOs. If I fill this with materials, it can use all the space up to 16.5k.
Kiruna STO Bug Inventory

I think there is a bug with EXTLNK

EXTLNK https://i.imgur.com/9RZwqBV.png

Put the above into a buffer, when you click the button, just returns a 404 not found from imgur.

I think the file extension at the end of the URL is getting terminated for links that contain them

Getting that same behavior clicking that link here (looks to me like it’s imgur doing the terminating).

Woah it happens here on the forum as well. What the heck is going on.

It’s a valid URL… like, it works if you copypasta it and go there directly.

That’s very strange.

Now it works just by clicking it (ingame as well). Maybe just a temporary imgur issue?

Same. Workaround is to reload apex and go right to the BRA command. If I go to the base first it won’t show on BRA. That is for my first base only.

1 Like

Neat trick, thanks. I had to start a new screen with only the BRA buffer to open first for it to work. My starting screen has my first base production queue on it, as soon as that loads BRA won’t register the base anymore


I was doing some manual data mining (as part of my work as governor of Montem) and discovered a partly-visual, partly-functional bug with the buffer system. Once a user opens enough buffers to cover the whole width of their screen and exceeds this number of open buffers, the screen shifts up to make way for the extra buffers which are displayed in the whitespace below. Scrolling up on the APEX Interface won’t cause the screen to return to top, disabling the notification bar and whatever else was displayed at the top.

A better implementation of the buffer system is if it worked more similarly to Google Sheets/Microsoft Excel, where you could page/scroll through the list of buffers, without what happens on the APEX interface.

Yes I know this is an edge case, and yes I know this probably wouldn’t affect 99.99% of users, but it’s a small quality of life fix that would put my mind at ease :smiley:

2 Likes

Apex is unplayable for me since the update. Will return a few screens and crash now. Tried to send a few contracts this morning, one went through, the rest hung on in-progress until red screen crash. Now It loads the side bars, and just red screens.

I am sorry, we still have stability issues with the servers. We are working on it and will post an update here as soon as they are resolved. Thanks for your patience!

4 Likes

Would this also cover ship flights? I always get the error: unable to render???

Flight control component fails to render due to javascript error:

Will fix the flight control issue tomorrow morning.

Very small issue, i can no longer left click and drag the horizontal scroll bar on buffers. Vertical scroll bar works normally by dragging and by mousewheel, and both bars will move with a middle mouse click.

After playing with it for a bit, i can still grab the scroll bar but only on the bottom few pixels

bug: when editing contract conditions, the enter key doesn’t save the edited contract condition like it used to. This decreases efficiency on APEX licencees who access the APEX terminal primarily on laptops.

The destination dropdown in ship flight control does not scroll, making selection difficult if you have a large number of bases/warehouses or a small screen.

Can we get the MTRA buffer to actually list the location for Base and Warehouse? Playing guess which base or warehouse the ship is attached to is not fun especially on a smal screen as the list autoscrolls and you loose your place in the list of base storage locations.
Or possibly have an option to select the ship cargo hold (which is named) and have the associated locations appear in a second drop down.

1 Like

That is a good suggestion. I added a ticket for it. Can’t promise when we’ll get around to implement it though

1 Like