Bugs and Improvements


#181

I think there might be decimals, we can not see. So there actually was 99.x in storage, thus keeping you from adding one unit. By removing all of it, the hold was actually empty again and could take 100 units


#182

I am not sure. Internally we use a integer-like data type for units, since a single unit is already the smallest unit. If it’s a rounding error then it has to be somewhere in the weight/volume capacity.


#183

if “1” is the smallest quantity, how do 1.5 beer/100p work?


#184

If the daily need is 1.5 units of beer per 100 population there are two cases:

  • if you have >= 2 units of beer, 2 units will be consumed and your population will be happy for a bit longer than one day
  • if you have only 1 unit of beer that unit will be consumed and the population’s satisfaction is 66%

#185

Then why my settlers consumed only 1 beer the third day, even i had 8 beer in stock?


#186

Quick side note: Has your question regarding the (in)correct ship been resolved, @Fiszstar? (I can’t recreate the situation right now because I’m a hermit living far away from the rest of civilization. :smile: )


#187

@Mjeno, I will check the settings of the ships tomorrow once more, when my two ships will be in Promitor.
However when the stuff is buying it goes to the first ship when I had selected the second ship.


#188

That might be due to a misunderstanding: The location field in the CX order form is irrelevant for BUY orders. It’s just there for SELL orders when you need to select where to take the material from. Several people have had issues with this before…we might have to adjust the form to make it clearer.


#189

I’ve jokingly said this in the chat, but I’m actually thinking it could be valuable. Any chance we could trade experts in the future. More of a pro-sports trading rather than a slave-trading, of course.
At this point, I’m generating them a lot faster than I can use them. And I think we’ll generate them from branches we don’t necessarily plan to expand, so the surplus could be commoditized.
Just an idea.


#190

I like the idea of trading experts as well, and we have talked about it in the team. We might add this at a later point in time. The generation of experts will be a slower in the next test, since we also think that they drop too fast.


#191

cannot insert ‘PRODQ’ into a tile by typing in the command, says illegal command. Can only insert to tile when opened by production menu and dragged into it


#192

Thanks, @buffmech! I tried to reproduce the error but it worked as intended on my end. The PRODQ command needs to be followed by a so-called parameter, in this case by the identifier of a concrete Production Line, which is a sequence of numbers and letters. You can see it at the top of the PRODQ buffer:

For more info on parameters, watch the bit starting at 0:50: https://youtu.be/9CvjpLP4tZY?t=50s

I talk about PRODQ at around 4:22: https://youtu.be/9CvjpLP4tZY?t=4m22s


#193

Yes, I was informed of this in the in-game global chat by yukawa but, the problem is now I can’t delete my post as if to say it were solved. Maybe, I’ll just reply to it with solved


#194

@buffmech post is answered and i can’t delete


#195

Okay! :smile: I think it’s something that’ll come up again in the future, so it’s probably handy to keep the question and my answer in here.


#196

On day 4 they consumed 2 beer again.
I’ve loaded the tech2 food in a ship now, because i don’t need satisfied settlers atm.


#197

I can’t open the game now, is there some sort of maintenance going on right now that I don’t know about? I have tried in 3 different browsers and it all says “Not Secure” and is stuck on the green loading circle. Please help, I have been trying all morning.


#198

@buffmech After waiting 48 minutes on the Firefox instance, it finally cleared the green circle. I don’t think this is from my internet as its more than enough for 4K streams at about 300Mbps up and down. The buffers all load in very slowly and the PU Rock on the top corner is always spinning no matter how many reloads I do.


#199

If you experience connection issues, join them on their Discord, usually you’ll get a much more immediate response there.


#200

During the current test, connection to some players has been lost now and then. This wasn’t an issue before and we’re trying to figure out what the problem is. If APEX is down, check back soon - it’s never lasted more than an hour or two to my knowledge. And yeah, ideally give us a heads up Discord and tag one of the coders @molp or @martin. :slight_smile: Sorry for the inconvenience!