APEX stuck in loading phase

APEX won’t load for me - it just spins in the loading screen. I’ve sent in an email to the PU team already but if I have any contract partners wondering what is going on I wanted to post a message here. Hopefully they’ll be able to clear it up on Monday (Sunday afternoon here).

Wow! That is not supposed to happen.

This was resolved with today’s update. Thanks to the simulogics team.

Back to finding shipping contracts…

1 Like

I’m getting this again. Have been stuck loading for hours

1 Like

It looks like APEX is unresponsive for everyone. The interface doesn’t even get to the “APEX loading please wait” message.

When I initially reported this issue the side, top, and bottom bars loaded with the loading flashing bits in the middle constantly going.

So, a different problem I think. Plus servers were really slow about 10 hours ago too.

Same here - lots of timeouts from what it looks like. Tried multiple browsers and machines.

Was working for awhile after the update but has been broken for several hours now.
I get pop ups telling me about events on my base at “hydration timeout”, ship arrivals etc so the back end is running fine but the base screen never arrives and while I can select other screens from the top or sidebar, they never load.

Different machines, differen browsers, different OSs, all do the same.

Was fixed for a couple of hours but it looks like it is broken again?

We are still investigating … servers should be back soon

And again its stuck loading. I haven’t been able to play at all last few days. Every time I’ve tried the game has either been so slow as to be unplayable or not loading at all.

1 Like

They are already back up.